Samsung Galaxy S3 – WLAN-Probleme mit Speedport und Bridge gelöst

In einem Netzwerk mit Speedport W 504V (Router) und Speedport W 101 Bridge (Repeater) hatte ich Probleme, eine stabile WLAN-Verbindung mit meinem S3 zu bekommen. Im Netz finden sich dazu auch verschiedene Berichte und Lösungsvorschläge, von denen keiner bei mir das Problem löste. Die aktuelle Konfiguration des Speedport W 504V:

  • Übertragungsmodus: 802.11a + 802.11n (wird im Handbuch empfohlen, wenn man IP-TV an dem Gerät nutzt)
  • Sendeleistung: Hoch
  • Kanal: Auto (kleinere Werte als 36 lassen sich nicht auswählen)
  • Geschwindigkeit: max. 300 Mbit/s
  • Sicherheit: WPA/WPA2 (auch WPA2 hatte ich getestet, aber damit reproduzierbar schlechtere Empfangssignale zwischen Router und Bridge)

Mit der gleichen Konfiguration hatte ich keinerlei Empfangsprobleme mit meinem HTC Desire. Mit dem S3 hatte ich im Wohnzimmer fast im Sekundentakt Verbindungen und Verbindungsabbrüche, so dass keine stabile Verbindung zustande kam. Selbst kleine Apps konnten so nicht aus dem Google Play Store installiert werden. Da ich dieses Verhalten im Büro mit dem S3 trotz schwacher Signalstärke nicht beobachtet habe, scheint kein grundlegendes Problem mit dem S3-WLAN-Modul vorzuliegen.

Bevor ich zur Lösung komme, hier noch ein paar technische Hintergründe, zitiert aus dem Bridge-Handbuch (11/2009, Seite 13):

Wenn die Speedport W 101 Bridge und der Speedport WLAN Router miteinander verbunden sind, dann

  • werden WLAN-Geräte, die mit 2,4 GHz-Verbindungen (802.11 b/g/n) am Speedport WLAN-Router angemeldet waren, jetzt automatisch mit der Speedport W 101 Bridge verbunden und können sofort weiter verwendet werden.
  • bleiben WLAN-Geräte mit 5 GHz-Verbindungen (802.11 a/n) am Speedport WLAN-Router angemeldet und können wir gewohnt genutzt werden. […]

Über »*#0011#« im Telefon des S3 und dann unter WiFi konnte ich sehen, dass mein Gerät mit 2,4 GHz im n-Standard funkte und erwartungsgemäß mit der Bridge verbunden war. Nachdem ich die Bridge ausgesteckt hatte, verband sich das S3 nicht automatisch mit dem Router – trotz gleicher (unsichtbarer) SSID und gleichem PSK. Also habe ich ein neues Netzwerk mit den entsprechenden Daten angelegt. Daraufhin verband sich das S3 mit dem Router im 5-GHz-Bereich – und ich hatte eine stabile WLAN-Verbindung! Die Bridge wird allerdings benötigt, um in einem anderen Raum einen IP-TV-Receiver zu betreiben. Nachdem die Bridge wieder angeschlossen war, blieb das S3 zunächst mit dem Router im 5-GHz-Band verbunden. Nach einem Neustart des Routers war das S3 im 2,4-GHz-Band mit der Bridge verbunden. Zu einem späteren Zeitpunkt war das S3 wieder mit dem Router verbunden.

Es scheint also nun so zu sein, dass das S3 zwischen Router und Bridge wählt; ich vermute abhängig von der Signalstärke. Im Wohnzimmer ist das Router-Signal stärker, im Rest der Wohnung das Bridge-Signal. Somit scheint sich zumindest für mich das Problem mit der stabilen WLAN-Verbindung des S3 gelöst zu haben. Vielleicht können andere Nutzer das in ihrem Netzwerk verifizieren.

Drucker an einem Speedport W 504V unter Ubuntu 11.10 installieren

Neulich erst habe ich mir mal die Funktionsmöglichkeiten des USB-Anschlusses an meinem Speedport W 504V angesehen und dabei festgestellt, dass man darüber einen Drucker im Netzwerk zur Verfügung stellen kann. Die Treiber müssen allerdings auf den Rechnern, die den Drucker nutzen wollen, direkt installiert werden. Die Installation dieses Druckers läuft unter Ubuntu wie folgt ab. Der Drucker muss an den Speedport angeschlossen und eingeschaltet sein und in der Speedport-Konfiguration angezeigt werden.

Zunächst wird in der Sitzungsanzeige oben rechts im Panel der Punkt »Drucker« ausgewählt:

Sitzungsanzeige

Drucker in der Sitzungsanzeige auswählen

Es öffnet sich das Dialog-Fenster »Neuer Drucker«. Dort wählt man unter Netzwerkdrucker LPD/LPR-Host oder -Drucker und trägt unter Host die interne IP-Adresse des Speedports ein. Bei der Auslieferung ist 192.168.2.1 eingestellt. Wer dies geändert hat, weiß dann auch, was unter Host einzutragen hat. Vermutlich würde auch einfach speedport.ip funktionieren, was ich aber nicht ausprobiert habe. Unter Warteschlange trängt man lpt1 ein. Als Nächstes klickt man auf »Vor«.

Dialog »Neuer Drucker«

Dialog-Fenster »Neuer Drucker«

Es erscheint der Dialog zum Auswählen des Druckertreibers. Bei dem von mir angeschlossenen Drucker konnte ich den Drucker nach Angabe des Herstellers und anschließend des Modells aus der Datenbank auswählen. Man wählt also zunächst den Hersteller aus (in meinem Fall Samsung) und im nächsten Fenster das Modell (in meinem Fall ML-2010; ohne Bildschirmfoto). Bei einem PostScript-fähigen Drucker kann man auch die mit dem Drucker gelieferte PPD-Datei verwenden.

Drucker-Treiber auswählen

Drucker-Treiber auswählen

Die folgenden Dialoge kann man nach Bedarf anpassen und stellt dann die Installation fertig. Anschließend erscheint das Fenster mit den Drucker-Eigenschaften. Damit seid Ihr eigentlich schon fertig. Im Fenster mit den Drucker-Eigenschaften kann man weitere Einstellungen vornehmen, die als Voreinstellungen beibehalten werden. Über »Testseite drucken« könnt Ihr testen, ob die Installation bei Euch funktioniert hat.